• Advertisement

VLANs with an older Catalyst 2924XL

This is for more general topics about networking and vendors.

VLANs with an older Catalyst 2924XL

Postby Guest » Wed Jun 02, 2010 2:53 am


I have an older Catalyst 2924XL with 11.2 (8) SA6 IOS (the latest I could find for the older 4mb/1mb switches) and I want to integrate it into my network.  The problem is I have 5 VLANs running and I can't get it to trunk anything (ie.  It doesn't have any of the normal trunking commands, like switchport mode trunk).  So I thought, well at the very least I should be able to set it up off of another switch with that port in one VLAN and then all the ports on the 2924 will be in that one VLAN right?  Well I can't get it to work.....does anyone have any ideas?  Thanks in advance guys!

Guest
 

Advertisement

Re:VLANs with an older Catalyst 2924XL

Postby Guest » Wed Jun 02, 2010 3:15 am


    I'm not sure the older 2924's were able to handle trunking at least non enterprise edition 4 meg boxes . 

Guest
 

Re:VLANs with an older Catalyst 2924XL

Postby Guest » Wed Jun 02, 2010 4:12 am


Really?  I guess I was confused becuase, with this version of IOS there is a vlan database and vtp commands.  But there is no switchport mode trunk command, only switchport mode multi and switchport mode access.  It's a bummer cause I can't upgrade the memory and I can't seem to even get it to act like a dumb switch (ie. Have all the ports in the same VLAN).  I would be perfectly happy if I could get it to act as a dumb switch.

Guest
 

Re:VLANs with an older Catalyst 2924XL

Postby Guest » Wed Jun 02, 2010 5:26 am


    You should be able to run it as a regular switch  as long as all the ports are in the same vlan , by default with these switches every port is in vlan 1 unless otherwise changed  , we have  hundreds of these in our network .   You can still define separate vlans for the switch you just can't trunk them  to another device .    This is just off the top of my head so someone can correct me if I am wrong .   If you want to get them back to factory defaults , at the command line issue the "write erase" command and then reload without doing a write mem and this will load factory defaults with nothing configured .

Guest
 

Re:VLANs with an older Catalyst 2924XL

Postby Guest » Wed Jun 02, 2010 5:46 am


I should have posted that I figured out my problem!  Thanks for the feedback it is most appreciated.  You are exactly correct in what my problem was.  I was putting all of the ports in a certain VLAN instead of leaving it in the admin vlan 1.  Then I just put the "mother switch" (-technical term, hehe) port in the VLAN that I wanted and it worked perfectly!  I was just thinking to hard about this problem and I should've just done a quick 'write erase' and started from scratch.  Thanks again for all the posts they were very helpful!

Guest
 

Next


  • Advertisement


Similar topics


Return to Anything Networking

Who is online

Users browsing this forum: No registered users and 2 guests

cron