• Advertisement

MPLS over GRE tunnels

This is for more general topics about networking and vendors.

MPLS over GRE tunnels

Postby Guest » Sun Oct 25, 2009 8:43 am


Hello everybody,

I need some help in configuring MPLS over GRE tunnels. I did not find any proper configuration example to help me. I need to do this for encrypt the traffic between two PE routers. I have 7609 routers.

Thanks,

Alexandru.

Guest
 

Advertisement

Re:MPLS over GRE tunnels

Postby Guest » Sun Oct 25, 2009 9:27 am


Hi,

The same configurations of regular IP over GRE should be applied over physical interfaces, once the tunnel get ip, establish your routing protocol and LDP over the tunnel interface, based on the MPLS application you gone use decied the maximum number of labels will be included in one packet (4 bytes per label) then add the 24 GRE header and adjust your MTU.

Best Regards,

Mounir Mohamed

Guest
 

Re:MPLS over GRE tunnels

Postby Guest » Sun Oct 25, 2009 10:08 am


I understand. But, I really don't know how can I configure. I tray something but it isn't working.

I cannot establish the MP-BGP session over my GRE tunnel. I made the GRE tunnel and I put the GRE interface into one VRF.

I'm a little bit lost and I need a configuration example to have a starting point.

Thanks,

Alexandru Nitulescu

Guest
 

Re:MPLS over GRE tunnels

Postby Guest » Sun Oct 25, 2009 10:25 am


Hello alexandru,

one thing is to have a GRE tunnel as a VRF access link, another different matter is to use the GRE tunnel as your backbone link between PE routers.

in a few words to support MPLS forwarding and signaling you enable MPLS into the tunnel interface with mpls ip command.

PE1

 

interface tunnel 12

tunnel source <local PE pub ip address>

tunnel destination < remote PE pub ip address  >

ip address 10.x.y.1 255.255.255.252

mpls ip

! some mtu fixing may be necessary

interface loop5

ip address 172.16.12.1 255.255.255.255

an IGP running over 10.x.y.0/30 + mpls ldp router-id loop5 or change mpls source on the tunnel

router ospf 12

network 10.x.y.0 0.0.0.3 area 0

network 172.16.12.1 0.0.0.0 area 0

!

router bgp 12

address-family vpnv4

neighbor 172.16.12.2 activate

neighbor 172.16.12.2 update-source loop5

neigh  172.16.12.2 send-community both

Constraint:

the public ip addresses are different from 10.x.y.0/30 and 172.16.12.x and must be known / advertised

public ip addresses mustn't be advertised over IGP running over GRE tunnel (try and see what happens ...)

hope to help

Giuseppe

Guest
 

Re:MPLS over GRE tunnels

Postby Guest » Sun Oct 25, 2009 10:27 am


Thanks a log for helping me. I will try to configure in the way you suggest next week to see what's happen'.

Guest
 

Next


  • Advertisement


Similar topics


Return to Anything Networking

Who is online

Users browsing this forum: Google [Bot] and 3 guests