• Advertisement

ASA 5505 FTP port forwarding - help!

Firewalls, PIX, ASA, VPN, Access Control List, User Authentication, Data Encryption and Best Practices.

ASA 5505 FTP port forwarding - help!

Postby mistersir » Fri Apr 13, 2012 1:09 pm

I need some assistance with my config. I thought I had it right because all my other port forwards are working but no luck with FTP. Any advice please?



ASA Version 8.2(5)
!
hostname ciscoasa
enable password bMN53GxNoKlQNrTC encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 23.24.241.50 255.255.255.248
!
ftp mode passive
object-group service DM_INLINE_SERVICE_1
service-object gre
service-object tcp eq pptp
object-group service gre tcp
description 500
port-object eq 500
object-group service DM_INLINE_TCP_1 tcp
port-object eq www
port-object eq https
object-group service DM_INLINE_TCP_2 tcp
port-object eq ftp
port-object eq ftp-data
access-list outside_access extended permit tcp any interface outside eq smtp
access-list outside_access extended permit tcp any interface outside object-group DM_INLINE_TCP_1
access-list outside_access extended permit object-group DM_INLINE_SERVICE_1 any interface outside
access-list outside_access extended permit gre any interface outside
access-list outside_access extended permit tcp any interface outside eq pptp
access-list outside_access extended permit tcp any interface outside object-group DM_INLINE_TCP_2
access-list internalout extended permit ip any 192.168.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.12 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.12 https netmask 255.255.255.255
static (inside,outside) tcp interface pptp 192.168.1.12 pptp netmask 255.255.255.255
static (inside,outside) tcp interface 500 192.168.1.12 500 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.12 www netmask 255.255.255.255
static (inside,outside) tcp interface ftp 192.168.1.12 ftp netmask 255.255.255.255
access-group outside_access in interface outside
route outside 0.0.0.0 0.0.0.0 23.24.241.54 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect pptp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:42f09ce2e4f14b07a896b81bcacdbcfd
: end
no asdm history enable
mistersir
Hello I'm new here
 
Posts: 2
Joined: Fri Apr 13, 2012 1:01 pm

Advertisement


  • Advertisement


Similar topics


Return to Cisco Security

Who is online

Users browsing this forum: No registered users and 3 guests

cron