• Advertisement

Cannot ping across nme-x-23es-1g and Cisco 2851

Static, RIP, EIGRP, OSPF, BGP, IBGP, IS-IS and any other routing.

Cannot ping across nme-x-23es-1g and Cisco 2851

Postby ClmsnOrang » Tue Jul 12, 2011 12:55 pm

I am using a nme-x-23es-1g inside of a 2851. A device on GE0/0 of the 2851 can ping all interfaces of the 2851, including the router's ip link to the nme-x-23es-1g. An attempt to ping anything on the nme-x-23es-1g side (the interfaces of the nme-x-23es-1g or anything connected) results in "Destination host unreachable" from a Windows PC.

The opposite is also true. Any pc connected to the nme-x-23es-1g cannot ping anything outside of the IPs on the nme-x-23es-1g.

The 2851 can ping all devices connected to it and all IPs associated with the nme-x-23es-1g interfaces. The 2851 cannot ping any device connected to the nme-x-23es-1g.

The nme-x-23es-1g can ping all devices connected to it and all IP's associated with the 2851 interfaces. The nme-x-23es-1g cannot ping any device connected to the 2851.

I simply need GE0/0 on the 2851 and FE1/0/2-24 on the nme-x-23es-1g to be able to route back and forth.

This seems like a simple routing problem, but I have not been able to resolve this. Any help would be greatly appreciated. Configs are below. Thanks in advance.

Switch Module:
!
version 12.2
!
hostname Switch
!
logging buffered 8192 informational
enable secret 5 xxxxxxxxxxxxxxxxxxx
!
!
!
no aaa new-model
system mtu routing 1500
vtp domain lab
vtp mode transparent
ip subnet-zero
ip routing
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan 6,7,8,9,10,13,14,15,100,101,102,103,104
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
description CONNECTS TO 2851 Router
no switchport
ip address 10.0.0.2 255.255.255.0
!
interface FastEthernet1/0/2
!
.........
!
interface FastEthernet1/0/23
switchport access vlan 9
!
interface FastEthernet1/0/24
switchport access vlan 100
!
interface Vlan 9
ip address 192.168.9.1 255.255.255.0
no shutdown
ip directed-broadcast
!
interface Vlan 100
ip address 192.168.16.1 255.255.255.0
no shutdown
ip directed-broadcast
!
ip classless
ip forward-protocol udp 40000
ip forward-protocol udp 40003
ip forward-protocol udp 40010
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 192.168.6.0 255.255.255.0 192.168.16.2
ip route 192.168.7.0 255.255.255.0 192.168.16.2
ip route 192.168.8.0 255.255.255.0 192.168.16.2
ip route 192.168.10.0 255.255.255.0 192.168.16.2
ip route 192.168.13.0 255.255.255.0 192.168.16.2
ip route 192.168.14.0 255.255.255.0 192.168.16.2
ip route 192.168.15.0 255.255.255.0 192.168.16.2
!
ip http server
!
logging facility local6
!
control-plane
!
line con 0
line vty 0 4
password 7 xxxxxxxxxxxxx
login
line vty 5 15
no login
!
end
-------------------------------------------
2851 Router:
!
version 12.4
!
hostname Router
!
!
logging buffered 8196 informational
enable secret 5 xxxxxxxxxxxxxxxx
!
ip subnet-zero
!
interface GigabitEthernet0/0
description CONNECTS WAN
ip address 192.168.17.2 255.255.255.0
duplex auto
speed auto
no ip directed-broadcast
ip nat outside
no shutdown
!
interface GigabitEthernet0/1
description Connects future uses
ip nat outside
shutdown
!
interface GigabitEthernet1/0
description CONNECTS Switch Module
ip address 10.0.0.1 255.255.255.0
ip directed-broadcast
ip nat inside
no shutdown
!
!
ip nat inside source static 192.168.9.81 192.168.17.81
ip nat inside source static 192.168.9.87 192.168.17.87
!
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip forward-protocol udp 40000
ip forward-protocol udp 40003
ip forward-protocol udp 40010
!
ip route 0.0.0.0 0.0.0.0 192.168.17.1
ip route 192.168.6.0 255.255.255.0 10.0.0.2
ip route 192.168.7.0 255.255.255.0 10.0.0.2
ip route 192.168.8.0 255.255.255.0 10.0.0.2
ip route 192.168.9.0 255.255.255.0 10.0.0.2
ip route 192.168.10.0 255.255.255.0 10.0.0.2
ip route 192.168.13.0 255.255.255.0 10.0.0.2
ip route 192.168.14.0 255.255.255.0 10.0.0.2
ip route 192.168.15.0 255.255.255.0 10.0.0.2
!
logging facility local6
!
line con 0
transport input none
line aux 0
line vty 0 4
password 7 xxxxxxxxxxxxx
login
!
end
ClmsnOrang
Hello I'm new here
 
Posts: 1
Joined: Tue Jul 12, 2011 12:18 pm

Advertisement

Re: Cannot ping across nme-x-23es-1g and Cisco 2851

Postby kyledotroberts » Sat Aug 20, 2011 1:23 am

Hi ClmsnOrang

After a quick look through, it appears as though maybe you're missing a static route on your Cisco2851 for the Vlan100 range of 192.168.16.0/24

>> ip route 192.168.16.0 255.255.255.0 10.0.0.2

You'd be able to ping from the switch module to the route as it would source the ping from the point-to-point which it does know a route to.

If you try and do a "show ip route 192.168.16.1" on the 2851 there is a good chance it'll come back with "%network not in table" and instead the traffic would attempt to follow your default route towards your WAN interface.

Try that :)
kyledotroberts
Hello I'm new here
 
Posts: 4
Joined: Wed Jun 01, 2011 11:40 am



  • Advertisement


Similar topics


Return to Routing Protocols

Who is online

Users browsing this forum: Google [Bot] and 1 guest